[Hippo-cms7-user BETA] First impressions

Bart Schuller schuller at lunatech.com
Wed Oct 1 20:35:37 CEST 2008


Hello,

A quick introduction: at Lunatech we do a lot of development work for  
Sdu Publishers, who are Hippo 6 users and are considering CMS 7 for a  
new project. In the past few weeks I've built from trunk just to see  
what it's like from the perspective of an interested developer, but  
Arjé encouraged me to try the beta releases and give feedback here.  
So, with that out of the way, here starts the feedback.

Documentation: The primary way to learn about CMS7 is via http://docs.onehippo.org/ 
  which guides you to the quickstart page. Vaguely remembering some  
problems in my existing appserver and having run with jetty from svn,  
I tried grabbing the quickstart binary package with Jetty. That link  
is broken, it ends in .ear and gives a "not found" page.

Application server compatibility: We are JBoss users, so the next  
thing I grabbed was the .ear version. I deployed it in an otherwise  
empty default jboss-4.2.2.GA installation and started it up. It made  
encouraging noises, but threw nasty errors later on, preventing it  
from starting up. The show stopper is this one:

22:37:48,387 ERROR [STDERR] Sep 30, 2008 10:37:48 PM  
org.hippoecm.repository.RepositoryServlet init
INFO: Started an RMI registry on port 1099
22:37:48,423 ERROR [STDERR] Sep 30, 2008 10:37:48 PM  
org.hippoecm.repository.RepositoryServlet init
SEVERE: Cannot bind to address rmi://localhost:1099/hipporepository
javax.naming.CommunicationException [Root exception is  
java.rmi.ConnectIOException: non-JRMP server at remote endpoint]
	at  
com.sun.jndi.rmi.registry.RegistryContext.rebind(RegistryContext.java: 
138)

JBoss itself already listens on port 1099, so blindly trying to listen  
on that port again will fail.

I'd suggest treating this as a documentation issue as long as the beta  
releases don't work on jboss, but of course I hope the problem can be  
solved as well (preferably not with an instruction to change the jboss  
config).

Lastly, before the jboss attempt stranded, there was a lot of nasty  
noise which I also noticed when building from svn:

22:37:48,090 ERROR [STDERR] Sep 30, 2008 10:37:48 PM  
org.hippoecm.repository.LocalHippoRepository initializeNodecontent
SEVERE: Error initializing content for embedded-workflows.xml in '/ 
hippo:configuration/hippo:workflows' : illegal node type name:  
frontend:workflow: Unknown prefix: frontend
javax.jcr.InvalidSerializedDataException: illegal node type name:  
frontend:workflow: Unknown prefix: frontend: Unknown prefix: frontend
	at  
org 
.hippoecm 
.repository 
.jackrabbit 
.xml 
.DereferencedSysViewImportHandler 
.endElement(DereferencedSysViewImportHandler.java:316)
	at  
org 
.hippoecm 
.repository 
.jackrabbit 
.xml 
.DereferencedImportHandler.endElement(DereferencedImportHandler.java: 
195)
	at  
org 
.hippoecm 
.repository 
.jackrabbit 
.xml.DefaultContentHandler.endElement(DefaultContentHandler.java:134)
	at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown  
Source)

For all I know this may be technically harmless (with my svn build  
attempts I saw these stack traces, yet all tests passed), but it sure  
looks scary.

Thanks for listening,

-- 
Bart Schuller
schuller at lunatech.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.onehippo.org/pipermail/hippo-cms7-user/attachments/20081001/106a13b7/attachment.htm>


More information about the Hippo-cms7-user mailing list