[Hippo-cms7-user] Upgrading from 2.09.04 to 2.10.00

Frank van Lankvelt f.vanlankvelt at onehippo.com
Tue Dec 15 09:37:21 CET 2009


Hi Niels,

you need to change the declaration of the hippo namespace to
http://www.onehippo.org/jcr/hippo/nt/2.0.1.  CND files with the 2.0
version number are still accepted, XML files where the JCR namespace
is declared as an XML namespace are not.

You probably have some XML files where the hippo namespace is
declared.  This declaration can best be removed.  (it's there because
the JCR spec says it should be there in an export)

The updater modules are relevant when you have created your own
plugin, with it's own node types.

cheers, Frank

On Mon, Dec 14, 2009 at 4:00 PM, nvankampenhout
<nvankampenhout at yahoo.co.uk> wrote:
>
> I'm upgrading my project from 2.09.04 to 2.10.00. I think I need to update
> some namespaces in my configuration files, where can I find this info?
>
> I am also getting this error at startup: "Rejected old style configuration
> content". Will this disappear once I updated the namespaces?
>
> The announcement of 2.10.00 promised "automatic upgrade from 2.09 to 2.10"
> [1], but how does this work? The reference to the javadoc of UpdateModule is
> not very useful since UpdaterModule does not contain any javadoc as far as I
> can see (btw it would be very useful to have javadocs published online).
>
> Thanks,
> Niels
>
> [1] http://n2.nabble.com/New-Hippo-CMS-tag-2-10-td4106448.html#a4106448
> --
> View this message in context: http://n2.nabble.com/Upgrading-from-2-09-04-to-2-10-00-tp4164523p4164523.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/community.html
>



More information about the Hippo-cms7-user mailing list