[Hippo-cms7-user] dropdown/selectionlist (2.01.03) error after document export

Marnix Kok m.kok at tfe.nl
Wed Jun 30 13:46:19 CEST 2010


Hi,

I think I had the same problem you are experiencing at the moment. The 
selectionlist type is probably initialized after you want to initialize 
the content that use the node type. Look at the sequence number in the 
initialize node of the selectionlist type and try to set the sequence 
number of your content to a later number.

Hope this helps!

Cheers,

Marnix

On 06/30/2010 01:38 PM, Edwin B. wrote:
> Hi,
>
> I'm trying to implement the dropdown/selectionlist (version 2.01.03) in my
> CMS (version 2.12.15).
> See [1] for documentation.
>
> When I startup my CMS I can create a "waardelijst" document.
> So far so good.
>
> Then, after exporting my document.xml and restart the CMS I get this
> error-message:
>
> 30.06.2010 13:13:58 ERROR
> [org.hippoecm.repository.LocalHippoRepository.initializeNodecontent():682]
> Error initializing content for
> jar:file:myProject/trunk/cms/target/work/webapp/WEB-INF/lib/myProject-content-1.0-SNAPSHOT.jar!/myProject-documents.xml
> in '/content' : javax.jcr.InvalidSerializedDataException: illegal node type
> name: selection:valuelist: Unknown prefix: selection
>
> When I login into the console I can see a selection-node inside the
> "hippo:namespaces" node.
>
> Someone any suggestion on how to this get to work properly?
>
> Thanx in advance,
> Edwin
>
>
>
>
> [1] http://selection.forge.onehippo.org/release-notes.html
>    



More information about the Hippo-cms7-user mailing list