[Hippo-cms7-user] Re: 7.6 from archetype cms login page error

M Nair mnsweeps at yahoo.com
Thu Jun 2 08:57:09 CEST 2011


Woonsan

I undid my changes and then set the env opts via console...Still did not work :(

here are the prompts...

[mnair at enhfamdev08 bin]$ export 
CATALINA_OPTS="-Dlog4j.configuration=/mnt/enhfamwork/mnair/workspaces/jcr/repos/run_env.git/app_server/conf/log4j.xml"

[mnair at enhfamdev08 bin]$ echo $CATALINA_OPTS
-Dlog4j.configuration=/mnt/enhfamwork/mnair/workspaces/jcr/repos/run_env.git/app_server/conf/log4j.xml

[mnair at enhfamdev08 bin]$ ./catalina.sh run
Using CATALINA_BASE:   
/mnt/enhfamwork/mnair/workspaces/jcr/repos/run_env.git/app_server
Using CATALINA_HOME:   
/mnt/enhfamwork/mnair/workspaces/jcr/repos/run_env.git/app_server
Using CATALINA_TMPDIR: 
/mnt/enhfamwork/mnair/workspaces/jcr/repos/run_env.git/app_server/temp
Using JRE_HOME:        /usr
Using CLASSPATH:       
/mnt/enhfamwork/mnair/workspaces/jcr/repos/run_env.git/app_server/bin/bootstrap.jar

Jun 1, 2011 11:51:23 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal 
performance in production environments was not found on the java.library.path: 
/usr/java/jdk1.6.0_18/jre/lib/amd64/server:/usr/java/jdk1.6.0_18/jre/lib/amd64:/usr/java/jdk1.6.0_18/jre/../lib/amd64:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib

Jun 1, 2011 11:51:23 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-17020
Jun 1, 2011 11:51:23 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 802 ms
Jun 1, 2011 11:51:23 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jun 1, 2011 11:51:23 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.26
Jun 1, 2011 11:51:23 PM org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor host-manager.xml
Jun 1, 2011 11:51:23 PM org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor manager.xml
Jun 1, 2011 11:51:24 PM org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor site.xml
Jun 1, 2011 11:51:24 PM org.apache.catalina.realm.JAASRealm 
setUseContextClassLoader
INFO: Setting useContextClassLoader = true
log4j:WARN No appenders could be found for logger 
(org.springframework.web.filter.CharacterEncodingFilter).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more 
info.
Jun 1, 2011 11:51:32 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive cms.war
Jun 1, 2011 11:51:48 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory docs
Jun 1, 2011 11:51:48 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory examples
Jun 1, 2011 11:51:49 PM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory tomcat_default_ROOT
Jun 1, 2011 11:51:49 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-17020
Jun 1, 2011 11:51:49 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:17023
Jun 1, 2011 11:51:49 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/20  config=null
Jun 1, 2011 11:51:49 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 25918 ms





----- Original Message ----
From: Woonsan Ko <w.ko at onehippo.com>
To: Hippo CMS 7 development public mailinglist 
<hippo-cms7-user at lists.onehippo.com>
Sent: Wed, June 1, 2011 5:12:30 PM
Subject: Re: [Hippo-cms7-user] Re: 7.6 from archetype cms login page error

Also could you try to test it with command lines only?
For example, you can revert the changes in catalina.sh and run the following 
commands:

$ export 
CATALINA_OPTS="-Dlog4j.configuration=file:/tmp/app_server/conf/log4j.xml"
$ catalina.sh run


Woonsan


On 06/01/2011 05:07 PM, Woonsan Ko wrote:
> Strange..
> I just extracted your tar and ran it. At first, I met the problem: when I 
>entered a username in cms login page and enter tab button, the page was 
>refreshed with clearing the username field. So I couldn't log on.
> However, after I set log4j configuration, the error does not happen any more.
> 
> Did you change any log level in your log4j configuration to DEBUG level? If so, 
>please try with WARN level.
> I reported the following issue before because it tries to access a variable to 
>leave debug logs while the variable can be null.
> 
> https://issues.onehippo.com/browse/CMS7-5264
> 
> 
> Woonsan
> 
> 
> On 06/01/2011 04:59 PM, M Nair wrote:
>> Woonsan
>> 
>> I made sure that its called by passing invalid value to the catalina_opts and
>> found that its getting called..
>> 
>> anyway I followed your suggestion and moved the parameter setting to the top 
>>and
>> I still get the login error..So that did not help either.... I am still
>> wondering why should a log4j parameter cause a session login failure..
>> 
>> Thanks
>> 
>> 
>> 
>> ----- Original Message ----
>> From: Woonsan Ko<w.ko at onehippo.com>
>> To: Hippo CMS 7 development public mailinglist
>> <hippo-cms7-user at lists.onehippo.com>
>> Sent: Wed, June 1, 2011 4:36:09 PM
>> Subject: Re: [Hippo-cms7-user] Re: 7.6 from archetype cms login page error
>> 
>> Hi M,
>> 
>> If you modified the following line in catalina.sh,
>> 
>>     CATALINA_OPTS="$CATALINA_OPTS $JPDA_OPTS -Djava.net.preferIPv4Stack=true"
>> 
>> it's a wrong location. The script line will be executed only when jpda
>> option is used.
>> 
>> Try to add the CATALINA_OPTS line at the top just after the script
>> comment block, for example,
>> 
>> -->8-->8--
>> #   LOGGING_MANAGER (Optional) Override Tomcat's logging manager
>> #                   Example (all one line)
>> #
>>LOGGING_CONFIG="-Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager"
>>" 
>>
>> 
>> #
>> # $Id: catalina.sh 885002 2009-11-27 20:51:03Z markt $
>> #
>> ----------------------------------------------------------------------------- 

>> 
>> CATALINA_OPTS="-Dlog4j.configuration=file:/tmp/app_server/conf/log4j.xml" 
>> 
>> # OS specific support.  $var _must_ be set to either true or false.
>> cygwin=false
>> -->8-->8--
>> 
>> 
>> HTH,
>> 
>> Woonsan
>> 
>> 
>> On 06/01/2011 04:27 PM, M Nair wrote:
>>> Woonsan
>>> 
>>> I tried that but did not work. You can try in my project from the TAR i 
>send..
>>> 
>>> 1) I updated CATALINA_OPTS in catalina.sh in the /bin directory as follows.
>>> 
>>> 
>>> CATALINA_OPTS="$CATALINA_OPTS $JPDA_OPTS -Djava.net.preferIPv4Stack=true
>>> -Dlog4j.configuration=\"$CATALINA_BASE\"/conf/log4j.xml"
>>> 
>>> 2) I placed the 2 log4j files under /conf .
>>> 
>>> Restarted the service and got the same login error "Session expired, please
>>> login again.".  There is nothing in the log ...
>>> 
>>> Can you try these on my install where you could recreate it previously?
>>> 
>>> Thanks
>>> M
>>> 
>>> 
>>> 
>>> 
>>> ----- Original Message ----
>>> From: M Nair<mnsweeps at yahoo.com>
>>> To: Hippo CMS 7 development public mailinglist
>>> <hippo-cms7-user at lists.onehippo.com>
>>> Sent: Wed, June 1, 2011 3:50:16 PM
>>> Subject: Re: [Hippo-cms7-user] Re: 7.6 from archetype cms login page error
>>> 
>>> Thanks ..Trying it now..
>>> 
>>> 
>>> 
>>> 
>>> ----- Original Message ----
>>> From: Woonsan Ko<w.ko at onehippo.com>
>>> To: Hippo CMS 7 development public mailinglist
>>> <hippo-cms7-user at lists.onehippo.com>
>>> Sent: Wed, June 1, 2011 3:33:53 PM
>>> Subject: Re: [Hippo-cms7-user] Re: 7.6 from archetype cms login page error
>>> 
>>> Hi,
>>> 
>>> I reproduced your problem locally.
>>> I think you can have a workaround: You need to have a global log4j
>>> configuration.
>>> For example, with the current tar, you will not meet the login error in
>>> CMS with the following commands:
>>> 
>>> $ export
>>>CATALINA_OPTS="-Dlog4j.configuration=file:/your_catalina_base_path/conf/log4j.xml
>>>l 
>>>
>>> l
>>> 
>>> 
>>> -Xms256m -Xmx256m -XX:MaxPermSize=256m"
>>> $ ./catalina.sh run (or start)
>>> 
>>> Note you should set "log4j.configuration" system property in either
>>> command line or in catalina.sh file. (The remaining jvm options are not
>>> related to this problem.)
>>> You will need to copy the following files into $CATALINA_BASE/conf/:
>>> -
>>>http://svn.onehippo.org/repos/hippo/hippo-demos/hippo-go-green/trunk/conf/log4j.dtd
>>>d 
>>>
>>> d
>>> 
>>> 
>>> -
>>>http://svn.onehippo.org/repos/hippo/hippo-demos/hippo-go-green/trunk/conf/log4j.xml
>>>l 
>>>
>>> l
>>> 
>>> 
>>> 
>>> Also, maybe this problem seems related to
>>> https://issues.onehippo.com/browse/CMS7-5264 because it's related to
>>> logging configuration issue.
>>> 
>>> HTH,
>>> 
>>> Woonsan
>>> 
>>> On 06/01/2011 02:41 PM, M Nair wrote:
>>>> Folks
>>>> 
>>>> Here is my entire application in a TAR file includes the Tomcat container.
>> The
>>>> only thing you will need to change is the STORAGE path in the web.xml file
>> for
>>>> CMS. And once thats done you should be up and running to reproduce the 
admin
>>>> login issue.
>>>> 
>>>> http://www.4shared.com/file/e1N9BoYD/hippocms76.html
>>>> 
>>>> Its a free site so please wait 90 second before the file "hippocms76.tar"
>>>> download begins.
>>>> 
>>>> Thanks
>>>> 
>>>> 
>>>> 
>>>> ----- Original Message ----
>>>> From: M Nair<mnsweeps at yahoo.com>
>>>> To: Hippo CMS 7 development public mailinglist
>>>> <hippo-cms7-user at lists.onehippo.com>
>>>> Sent: Wed, June 1, 2011 1:02:26 PM
>>>> Subject: Re: [Hippo-cms7-user] Re: 7.6 from archetype cms login page error
>>>> 
>>>> Denis
>>>> 
>>>> Sorry but I am still not sure what you mean here :-((
>>>> 
>>>> I tried installing the 1.03.03 project again with file repository instead 
of
>>>> using my sql on Linux. I got the same session expired error. The only 
change
>>>> after unzip would be to change the repository location from
>> /tmp/mnair/hippo76
>>>> to something of your choice.
>>>> 
>>>> 
>>>> I will send a followup email on where you can download the file from ..
>>>> 
>>>> Thanks
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>>> ----- Original Message ----
>>>> From: Denis Ryabkov<d.v.ryabkov at gmail.com>
>>>> To: hippo-cms7-user at lists.onehippo.com
>>>> Sent: Wed, June 1, 2011 10:38:04 AM
>>>> Subject: [Hippo-cms7-user] Re: 7.6 from archetype cms login page error
>>>> 
>>>> With default artifactId order is not changed, all OK.
>>>> 
>>>> To reproduce:
>>>> mvn archetype:generate \
>>>> -DarchetypeRepository=http://maven.onehippo.com/maven2 \
>>>> -DarchetypeGroupId=org.onehippo.cms7 \
>>>> -DarchetypeArtifactId=hippo-archetype-website \
>>>> -DarchetypeVersion=1.03.03 \
>>>> -DartifactId=cms
>>>> 
>>>> Notice artifactId=cms!!!!!!!!!!!!!!
>>>> 
>>>> Frontend name can be changed in cms/src/main/webapp/WEB-INF/web.xml with
>>>> <init-param>
>>>> <param-name>config</param-name>
>>>> <param-value>cms</param-value>
>>>> </init-param>.
>>>> Login fixed, but cms does not work as needed either. So artifact id can't 
be
>>>> "cms".
>>>> 
>>>> 
>>>> 
>>>> 
>>>> -- View this message in context:
>>>>http://hippo.2275632.n2.nabble.com/7-6-from-archetype-cms-login-page-error-tp6425881p6428034.html
>>>>l 
>>>>
>>>> l
>>>> 
>>>> l
>>>> 
>>>> 
>>>> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
>>>> _______________________________________________
>>>> Hippo-cms7-user mailing list and forums
>>>> http://www.onehippo.org/cms7/support/forums.html
>>>> 
>>>> _______________________________________________
>>>> Hippo-cms7-user mailing list and forums
>>>> http://www.onehippo.org/cms7/support/forums.html
>>>> 
>>>> _______________________________________________
>>>> Hippo-cms7-user mailing list and forums
>>>> http://www.onehippo.org/cms7/support/forums.html
>> 
> 
> 


-- w.ko at onehippo.com    www.onehippo.com
Boston - 1 Broadway, Cambridge, MA 02142
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466

_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html




More information about the Hippo-cms7-user mailing list