[Hippo-cms7-user] Hippo CMS in subdirectory

Ard Schrijvers a.schrijvers at onehippo.com
Mon Apr 2 09:27:16 CEST 2012


On Sat, Mar 31, 2012 at 8:55 AM, Tobias G. Pfeiffer <tgpfeiffer at web.de> wrote:
> Hi,
>
> Am Freitag, 30. März 2012, 12:56 schrieb Minos Chatzidakis:
>> Proxy first the mysite.com/hippo to hippo.mysite.com, and proxy
>> hippo.mysite.com to the server where Hst is running. Hst should be
>> agnostic about the host.
>> The '/hippo' at the end of the url is not part of the host. So hst
>> cannot handle it.
>
> As Ard said, this way I can access the site, but still since it doesn't
> know it's actually living in a subdirectory for the end user, it will
> generate links pointing to /site -- and the reverse proxy doing the
> mysite.com/hippo -> hippo.mysite.com thing won't rewrite all those
> references; that would in fact mean deep inspection of the HTTP traffic.
>
> OK, but now I know it's at least not a trivial problem that everyone
> else has solved before. Using subdomains is a suboptimal thing because
> of the SSL certificate that's only valid for one domain. But I guess for
> the development instance, I can live with a manually added port number,
> i.e. mysite.com:1234/

Was it all about getting a development instance available as well? We
normally use different hosts for that, for example

localhost : dev env
test.example.com : test
acct.example.com : acct
www.example.com : prod

You can configure all these hosts in a single hst:hosts configuration
below different virtualhost groups

Take a look at [1], that should help

Regards Ard

[1] https://wiki.onehippo.com/display/CMS7/Hostname+Matching

>
> Thanks for your help
> Tobias
>
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html



-- 
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com



More information about the Hippo-cms7-user mailing list