[Hippo-cms7-user] 7.7.1 export/import problem

Unico Hommes u.hommes at onehippo.com
Tue Apr 24 12:58:55 CEST 2012


On Tue, Apr 24, 2012 at 12:45 PM, Nils Eckelt <n.eckelt at satzmedia.de> wrote:

> Same problem here. Some (most) changes in cms or console in content will
> result in duplicate nodes. I got errors in the output
> [INFO] [talledLocalContainer] 24.04.2012 12:39:26 WARN
>  [org.onehippo.cms7.autoexport.DeltaXML.processEvent():195] Change not
> handled by export: PropertyRemoved on
> /content/documents/htwww-de/common/hippo:paths. You will need to do this
> manually.
> Is this a bug in the autoexport module? Have I done something wrong during
> my update from 7.6.1 to 7.7.1?
>

Auto export has some limitations that prevent it from exporting any and all
changes you might make to your repository. The change above - that you
removed a property from somewhere in your content - is suspect to me. It is
not an error message but a warning that you did something to your
repository that could not be exported because that change is not supported.

Now auto export should just export that particualr change however, unless
the content at /content/documents/htwww-de/common was bootstrapped from a
content module not under its control. So possibly you have a different
content module that you include in your cms apart from the one under
./content . Either that or you have not configured auto export correctly.
Please take a look at
https://wiki.onehippo.com/display/CMS7/Automatic+export+add-on and verify
you have set up everything accordingly.

--
Unico


>
> Please help me. It's not possible to develop with this issue in the
> console.
>
> Best regards,
>  Nils
>
> 2012/4/13 Jeroen Hoffman <j.hoffman at onehippo.com>
>
>>
>> Are you sure the content isn't present twice in the content xml's?
>> Are you using two content modules?
>>
>> How about a full rebuild again, specifing different -Drepo.path value?
>>
>> Jeroen
>>
>>
>>
>> On 13-04-12 13:38, Mykhailo Kotsur wrote:
>>
>>> Yes, you are right!
>>>
>>> But now there is another problem. All data became duplicated.
>>>
>>> Mike.
>>> On Apr 13, 2012, at 12:09 PM, Jeroen Hoffman wrote:
>>>
>>>
>>>>
>>>> On 13-04-12 12:06, Mykhailo Kotsur wrote:
>>>>
>>>>> Hi all,
>>>>>
>>>>> I'm using 7.7.1 with autoexport addon just as described here:
>>>>> https://wiki.onehippo.com/**display/CMS7/Automatic+export+**add-on<https://wiki.onehippo.com/display/CMS7/Automatic+export+add-on>
>>>>>
>>>>> and automatic export actually works fine. But the problem is in
>>>>> import. I'm
>>>>> trying to perform fairly easy scenario:
>>>>>
>>>>> 1. I have a repository with some content;
>>>>> 2. I add some document (and I see the changes in filesystem).
>>>>> 3. I stop the repository and delete storage folder (which is located
>>>>> somewhere
>>>>> in /tmp and specified by option -Drepo.path=… )
>>>>> 4. I start hippo.
>>>>> 5. I expect to see the document I've created on step 2 and I don't see
>>>>> it.
>>>>>
>>>>> What can be wrong here?
>>>>>
>>>>
>>>> Step 3.5: rebuild the content jar and cms war?
>>>>
>>>> Jeroen
>>>> ______________________________**_________________
>>>> Hippo-cms7-user mailing list and forums
>>>> http://www.onehippo.org/cms7/**support/forums.html<http://www.onehippo.org/cms7/support/forums.html>
>>>>
>>>
>>> ______________________________**_________________
>>> Hippo-cms7-user mailing list and forums
>>> http://www.onehippo.org/cms7/**support/forums.html<http://www.onehippo.org/cms7/support/forums.html>
>>>
>> ______________________________**_________________
>> Hippo-cms7-user mailing list and forums
>> http://www.onehippo.org/cms7/**support/forums.html<http://www.onehippo.org/cms7/support/forums.html>
>>
>
>
>
> --
> Satzmedia GmbH
>
> Altonaer Poststraße 9
> 22767 Hamburg
>
> Tel: +49 (0) 40 - 1 888 969 - 0
> Fax: +49 (0) 40 - 1 888 969 - 200
> E-Mail: n.eckelt at satzmedia.de
>
> E-Business-Lösungen: http://www.satzmedia.de
>
> Amtsgericht Hamburg, HRB 71729
> Ust-IDNr. DE201979921
> Geschäftsführer:
> Dipl.-Kfm. Christian Satz
> Dipl.-Inform. Markus Meyer-Westphal
>
>
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.onehippo.org/pipermail/hippo-cms7-user/attachments/20120424/67cfd988/attachment.htm>


More information about the Hippo-cms7-user mailing list