[Hippo-cms7-user] Cargo broken since Friday

Bart van der Schans b.vanderschans at onehippo.com
Mon Sep 17 14:12:45 CEST 2012


It now works again.

Bart

On Mon, Sep 17, 2012 at 10:51 AM, Bart van der Schans
<b.vanderschans at onehippo.com> wrote:
> I'm looking into it. Something odd is going on...
>
> Bart
>
> On Mon, Sep 17, 2012 at 9:57 AM, Jeroen Reijn <j.reijn at onehippo.com> wrote:
>> Hi Wouter,
>>
>> yes this happened before. Thanks for notifying us. The older tomcat
>> artifacts are occasionally removed from the mirrors when they are not
>> the latests anymore.
>>
>> There used to be a section about this in our documentation, but I
>> can't find it any more (after the move to the new Hippo campus). Sorry
>> about that.
>>
>> You indeed found the correct way of resolving it. I'll create an issue
>> for it in JIRA so that it can be resolved in the archetype.
>>
>> Jeroen
>>
>> On Sun, Sep 16, 2012 at 2:16 PM, Wouter Danes <Wouter.Danes at hinttech.com> wrote:
>>> Hey guys,
>>>
>>>
>>>
>>> I did a reinstall on Friday and it appears the cargo profile of hippo can’t
>>> find the right tomcat anymore. I get the following error:
>>>
>>> [ERROR] Failed to execute goal
>>> org.codehaus.cargo:cargo-maven2-plugin:1.1.3:run (cargo-run) on project akv:
>>> Execution cargo-run of goal org.codehaus.cargo:cargo-maven2-plugin:1.1.3:run
>>> failed: Failed to download
>>> [http://apache.hippo.nl/tomcat/tomcat-6/v6.0-latest/bin/apache-tomcat-6.0-latest.tar.gz]:
>>> Can't get
>>> http://apache.hippo.nl/tomcat/tomcat-6/v6.0-latest/bin/apache-tomcat-6.0-latest.tar.gz
>>> to
>>> /home/wouter/.m2/repository/org/codehaus/cargo/cargo-container-archives/apache-tomcat-6.0-latest.tar.gz
>>> -> [Help 1]
>>>
>>>
>>>
>>> It appears the file actually is gone. If I set the following property in the
>>> parent pom.xml (overriding it from the cms-7-project pom), everything works
>>> again:
>>>
>>>     <properties>
>>>
>>>         <!-- Cargo Tomcat full version used for Tomcat tarball distribution
>>> url -->
>>>
>>>         <cargo.tomcat.full.version>6.0.35</cargo.tomcat.full.version>
>>>
>>>     </properties>
>>>
>>>
>>>
>>> So to me it appears that either the archetype is borked or someone deleted
>>> too much from apache.hippo.nl. J
>>>
>>> Any ideas?
>>>
>>>
>>>
>>> Met vriendelijke groet / Yours sincerely,
>>>
>>>
>>>
>>> ---
>>>
>>> Wouter Danes
>>>
>>> Competence Manager Hippo / Java / Alfresco
>>>
>>> Hinttech
>>>
>>>
>>>
>>> T: +31 6 1158 8264
>>>
>>> E: wouter.danes at hinttech.com
>>>
>>> @wouterdanes
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> Hippo-cms7-user mailing list and forums
>>> http://www.onehippo.org/cms7/support/forums.html
>>
>>
>>
>> --
>> Jeroen Reijn
>> Solution Architect
>> Hippo
>>
>> Amsterdam - Oosteinde 11, 1017 WT Amsterdam
>> Boston - 1 Broadway, Cambridge, MA 02142
>>
>> US +1 877 414 4776 (toll free)
>> Europe +31(0)20 522 4466
>> www.onehippo.com
>>
>> http://about.me/jeroenreijn
>> _______________________________________________
>> Hippo-cms7-user mailing list and forums
>> http://www.onehippo.org/cms7/support/forums.html
>
>
>
> --
> Amsterdam - Oosteinde 11, 1017 WT Amsterdam
> Boston - 1 Broadway, Cambridge, MA 02142
>
> US +1 877 414 4776 (toll free)
> Europe +31(0)20 522 4466
> www.onehippo.com



-- 
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com



More information about the Hippo-cms7-user mailing list