[Hippo-cms7-user] Node property initialization via updater

Frank van Lankvelt f.vanlankvelt at onehippo.com
Mon Sep 24 11:45:14 CEST 2012


sorry, it's not been fixed.  The 'type' argument is not supported in
the updater node impl.

cheers, Frank

On Thu, Sep 20, 2012 at 2:31 PM, Wouter Danes <Wouter.Danes at hinttech.com> wrote:
> It's a known issue, I thought it was fixed in the first half of this year. I reported the same issue around May.
>
> -----Original Message-----
> From: hippo-cms7-user-bounces at lists.onehippo.org [mailto:hippo-cms7-user-bounces at lists.onehippo.org] On Behalf Of Adolfo Benedetti
> Sent: donderdag 20 september 2012 14:29
> To: Hippo CMS 7 development public mailinglist
> Subject: [Hippo-cms7-user] Node property initialization via updater
>
> Hi *,
>
>
> We are using annotation based updaters. If we try to create and initialize a multi value string property, the only working solution that we've found is initializing the property with:
>
> node.setProperty("something:cool", new String[]{""});
>
> Otherwise we will get a Double at the property type.We also tried with:
>
> node.setProperty("something:cool", new String[]{}); node.setProperty("something:cool", new Value[]{});
>
> This is a known issue, or just the way that it should be?,
>
>
> Thank you,
>
>
> Adolfo Benedetti
> iprofs.nl
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html



-- 
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com



More information about the Hippo-cms7-user mailing list