[Hippo-cms7-user] Unable to set Taxonomy plugin up

Nikhil Mahajan nik10.mah at gmail.com
Wed Sep 26 12:13:11 CEST 2012


When you are trying to integerate taxonomy plugin in your project. You
would require Annotated.html. Otherwise taxonomies won't appear. I faced
faced this problem while inetegration. So just a thought it might helpful
for you.

On Wed, Sep 26, 2012 at 2:46 PM, David Martin <dmartin at ippon.fr> wrote:

> I forgot a last point, which can be an enhancement.
> Currently, there is no other way than using the console to add a new
> taxonomy (in our example, let's consider I want to add exampletaxonomy2
> aside exampletaxonomy).
> The CMS interface doesn't provide any menu when clicking on the arrow next
> to "taxonomy". The only message visible is "no actions available".
> It could be nice to be able to create a new taxonomy and edit its content
> only from the CMS interface.
>
> David
>
>
> On Wed, Sep 26, 2012 at 11:04 AM, David Martin <dmartin at ippon.fr> wrote:
>
>> Hi,
>>
>> Thank you for your answer, but things still aren't clear.
>> What's the purpose of this file: Annotated.html ?
>> I can't find any reference to it either in the documentation or in any
>> configuration file of the demo project. What am I supposed to do with it ?
>>
>> David
>>
>> On Tue, Sep 25, 2012 at 4:18 PM, Nikhil Mahajan <nik10.mah at gmail.com>wrote:
>>
>>> You need to use the layout Annotated.html in your project. You can find
>>> it in taxonomy-demo-content
>>> project/src/main/java/org.onehippo.taxonomy.demo.layout.
>>> And remember to crreate the taxonomy tree through cms.
>>> And for creating the documents in CMS you need to give the basedocument
>>> sepcification in you project's .CND file.
>>>
>>> Thanks
>>>
>>> On Tue, Sep 25, 2012 at 6:10 PM, David Martin <dmartin at ippon.fr> wrote:
>>>
>>>> Hi,
>>>>
>>>> I've read the taxonomy plugin documentation with a great attention, but
>>>> despite that, I'm unable to make it work... even on a fresh new project
>>>> built with the archetype.
>>>> I've tried with version 1.08.04 and 1.08.05, and no luck in both cases.
>>>> I've tried to run the plugin demo application, and didn't succeed
>>>> (can't compile the plugin trunk due to tests in error). If I force the
>>>> plugin version in the demo to 1.08.04 or 1.08.05, It barely works : I've
>>>> got some exceptions in the CMS (when saving a document with a taxonomy =>
>>>> exception) and in the site (unable to display the taxonomy tree : NPE).
>>>>
>>>> Did someone succeed in using this plugin in the latest versions ? What
>>>> are the recommended (I mean production ready) versions ?
>>>>
>>>> NOTE : there is a dead link in the documentation. On page
>>>> http://taxonomy.forge.onehippo.org/cms-configuration.html , the link
>>>> "example taxonomy tree" is broken.
>>>>
>>>> Any help would be appreciated.
>>>>
>>>> --
>>>> David
>>>>
>>>> _______________________________________________
>>>> Hippo-cms7-user mailing list and forums
>>>> http://www.onehippo.org/cms7/support/forums.html
>>>>
>>>
>>>
>>>
>>> --
>>> *Best Regards,*
>>> *Nikhil*
>>>
>>>
>>> _______________________________________________
>>> Hippo-cms7-user mailing list and forums
>>> http://www.onehippo.org/cms7/support/forums.html
>>>
>>
>>
>>
>>
>
>
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html
>



-- 
*Best Regards,*
*Nikhil*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.onehippo.org/pipermail/hippo-cms7-user/attachments/20120926/a713336f/attachment-0001.htm>


More information about the Hippo-cms7-user mailing list