[Hippo-cms7-user] Unable to set Taxonomy plugin up

Woonsan Ko w.ko at onehippo.com
Thu Sep 27 04:20:08 CEST 2012


Hi David,

I think you're right.
It doesn't have to add the user locale. We'd better remove that in 
TaxonomyEditorPlugin.java (L642-645).

Would you create a JIRA issue in 
https://issues.onehippo.com/browse/HIPPLUG for that? :)

Cheers,

Woonsan

[1] 
https://forge.onehippo.org/svn/taxonomy/taxonomy/trunk/addon/frontend/src/main/java/org/onehippo/taxonomy/plugin/TaxonomyEditorPlugin.java

On 9/26/12 9:28 AM, David Martin wrote:
> I don't see why it should make sense.
> Let's think about an Finnish company administering an English only
> website. For editors convenience, the CMS locale is Finnish, thus the
> whole CMS interface is in editors' mother language. Why should Finnish
> be part of the documents' locales since all the data are supposed to be
> in English (since the website is english only) ?
>
> Anyway, that is not an issue for me, I was just sharing my PoV about
> this ;-)
>
> David
>
> On Wed, Sep 26, 2012 at 3:15 PM, Jeroen Hoffman <j.hoffman at onehippo.com
> <mailto:j.hoffman at onehippo.com>> wrote:
>
>
>
>     On 26-09-12 12:36, David Martin wrote:
>
>                  Last point: I only want the taxonomy to be defined in a
>         single language.
>                  I've
>                  deleted all but one language from the JCR node
>
>         "content/taxonomies/____exampletaxonomy/____exampletaxonomy".
>         Let's say I've
>
>                  just let
>                  "fr". If the end user is connected to the CMS using
>         another language, for
>                  instance "en", when clicking on New (to add a new
>         category), both
>                  English and
>                  French appear in the drop down list, despite the single
>         language
>                  defined. Could
>                  be a bug?
>
>
>              You can configure those, see
>         http://taxonomy.forge.__onehip__po.org/category-____localization.html
>         <http://onehippo.org/category-__localization.html>
>
>
>         <http://taxonomy.forge.__onehippo.org/category-__localization.html
>         <http://taxonomy.forge.onehippo.org/category-localization.html>>
>
>
>         This is what I've done (editing the hippotaxonomy:locales
>         property and only let
>         one locale : 'fr'). But despite this configuration, limited to a
>         single locale
>         ('fr'), when connecting to the CMS with a different one (in my
>         case, connecting
>         with 'en' locale), both 'en' and 'fr' are visible in the drop
>         down list. Am I
>         missing something ?
>
>
>     This means you're logged into the CMS with English language. So the
>     logged in language is merged with the configured ones.
>
>     Makes sense right?
>
>
>     Jeroen
>     _________________________________________________
>     Hippo-cms7-user mailing list and forums
>     http://www.onehippo.org/cms7/__support/forums.html
>     <http://www.onehippo.org/cms7/support/forums.html>
>
>
>
>
>
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html
>


-- 
w.ko at onehippo.com     www.onehippo.com
Boston - 1 Broadway, Cambridge, MA 02142
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466


More information about the Hippo-cms7-user mailing list